EXCEL funkcja JEŻELI.BŁĄD()

EXCEL funkcja JEŻELI.BŁĄD()

Ten artykuł zawiera opis funkcji JEŻELI.BŁĄD, jej opis, składnię i przykłady zastosowania w programie Microsoft Excel.

Bardzo często przy pracy z EXCEL-em spotykamy się z różnymi typami błędów np: #N/D!, #ARG!, #ADR!, #DZIEL/0!, #LICZBA!, #NAZWA? i #ZERO!. Funkcja JEŻELI.BŁĄD() służy głownie do wyłapywania takiego typu błędów w formułach. Ale za jej pomocą możemy także sprawdzić czy dana formuła spełnia warunek logiczny PRAWCA/FAŁSZ.

Składnia funkcji JEŻELI.BŁĄD()

JEŻELI.BŁĄD(formuła ; wartość_jeżeli_wystąpi_błąd)

Wyjaśnienie:
formuła – to właśnie to wyrażenie jest sprawdzane w poszukiwaniu błędu
wartość_jeżeli_wystąpi_błąd – jeżeli w wyrażeniu "wartość_formuły" wystąpi błąd zwracana jest wartość z drugiego argumentu

Przykład zastosowania funkcji JEŻELI.BŁĄD()

Dla zobrazowania działania tej funkcji przygotowałem tabelę z danymi do dzielenia.

EXCEL funkcja JEŻELI.BŁĄD()

Teraz stworzymy nową kolumnę "Wynik dzielenia" gdzie będziemy chcieli uzyskać wynik dzielenia dzielnej i dzielnika.
W komórce C2 wpiszemy więc całą formułę z wykorzystaniem funkcji JEŻELI.BŁĄD() bo będziemy jeżeli otrzymamy błąd to chcemy żeby w odpowiedniej komórce pojawił się taki komunikat.

=JEŻELI.BŁĄD(A2/B2;"Błąd")

Pierwszym argumentem funkcji JEŻELI.BŁĄD() jest wynik z dzielenia komórek A2/B2. Jeżeli efektem tego dzielenia będzie błąd to funkcja zwróci wartość drugiego argumentu, czyli komunikat "Błąd". Jeżeli wynikiem dzielenia nie będzie błąd to funkcja zwróci po prostu wynik dzielenia. Utworzyliśmy więc naszą formułę w komórce C2, teraz musimy ją skopiować na pozostałe komórki w tabeli "wynik dzielenia". W tym celu klikamy na komórkę C2. W tym momencie w prawym dolym rogu tej komórki pojawi się mały czarny kwadracik.

EXCEL funkcja JEŻELI.BŁĄD()

Teraz należy "złapać" ten kwadracik kursorem i przeciągnąć aż do komórki C11. Efektem tego działania jest kolejny widok.

EXCEL funkcja JEŻELI.BŁĄD()

Funkcja już zwróciła wartości dla poszczególnych wierszy. Teraz poświęćmy chwilkę na analizę działania funkcji JEŻELI.BŁĄD(). W komórkach zaznaczonych czerwonym kolorem (rysunek poniżej) funkcja zwróciła wartość dzielenia, bo w żadnym z tych przypadków nie wystąpił błąd.

EXCEL funkcja JEŻELI.BŁĄD()

Kolejnym przypadkiem jest wiersz 8 gdzie w kolumnie "Wynik dzielenia" otrzymaliśmy wartość "Błąd". Tutaj funkcja JEŻELI.BŁĄD() zwróciła wartość drugiego argumentu bo wynik pierwszego argumentu jest błędny, bo nie istnieje dzielenie przez "0".

EXCEL funkcja JEŻELI.BŁĄD()

Zwróćmy jednak uwagę na ostatni przypadek kiedy jedną z wartości przy dzieleniu, dokładnie "dzielną", jest wartość "pusta". Excel nie traktuje wyniku tego dzielenia jako błąd więc funkcja JEŻELI.BŁĄD() nie zwraca wartości drugiego argumentu tylko zwraca wartość "0".

EXCEL funkcja JEŻELI.BŁĄD()

Inne zastosowanie funkcji JEŻELI.BŁĄD() jest sprawdzenie czy formuła w pierwszym argumencie jest poprawna czy nie. Stwórzmy jeszcze jedną kolumnę "Prawda/Fałsz" i jako pierwszy argument funkcji JEŻELI.BŁĄD() wpiszmy wyrażenie.

=JEŻELI.BŁĄD(C2=10;"Błąd")

W pierwszym argumencie mamy wyrażenie w którym chcemy sprawdzić czy wartość komórki z kolumny C jest równa 10. Jeżeli jest to jest "prawda", jeżeli nie to jest "fałsz". Fałsz w tym przypadku nie oznacza "błędu", musimy rozróżnić te dwie sytuacje. Efekt zastosowania funkcji poniżej.

EXCEL funkcja JEŻELI.BŁĄD()

Zwróć uwagę, że tylko w komórce D2 funkcja JEŻELI.BŁĄD() zwróciła wartość "PRAWDA" bo tylko komórka C2 jest równa 10.

Więcej wpisów na temat funkcji w programie Microsoft EXCEL znajdziesz <<<tutaj>>>.